Investigating Performance issue with Integrations (formerly only NetSuite Integrations)

Incident Report for Versapay

Resolved

This incident has been resolved.
Posted May 04, 2026 - 10:42 EDT

Update

We are continuing to work on a fix for this issue.
Posted May 01, 2026 - 12:18 EDT

Update

We’re experiencing a performance issue with Integrations related to end of month / start of month activities. We'll provide an update as soon as more information becomes available.
Posted May 01, 2026 - 11:18 EDT

Identified

We’re experiencing a performance issue with Netsuite Integrations related to end of month activities. We'll provide an update as soon as more information becomes available.
Posted Apr 30, 2026 - 11:49 EDT
This incident affected: Connectors (ERP Connector for NetSuite, ERP Connector for Microsoft Dynamics 365, ERP Connector for Sage Intacct, ERP Connector for MRI, General ERP Connectors, Cash Application Connector).