Collaborative AR - Monthly Statement PDF Attachment Issues

Incident Report for Versapay

Resolved

We have regenerated all outstanding Statements and distributed them appropriately. Thank you for your patience and understanding.
Posted May 06, 2026 - 12:29 EDT

Monitoring

We have identified the cause of the missing attachments, and have applied a fix for it. We are working on regenerating statement emails with the appropriate attachments for affected clients, and have been in touch directly to coordinate.
Posted May 05, 2026 - 18:35 EDT

Investigating

We're investigating an issue that caused some monthly statement emails to be sent without their PDF attachments. Our team is working to regenerate and resend the missing statements. We'll share an update once timing is confirmed.
Posted May 04, 2026 - 16:00 EDT
This incident affected: Collaborative AR (formerly ARC) (Platform, Invoice Print & Mail).