Investigating ACH Payment Failures with Collaborative AR and Payment Gateway

Incident Report for Versapay

Resolved

We have not observed any recurrence of the issue and have identified any affected clients and are working directly with them on further action required as necessary.
Posted Apr 25, 2025 - 17:28 EDT

Monitoring

A fix has been implemented, and we are monitoring the results. The team is now working on re-submitting any ACH payments that failed.
Posted Apr 25, 2025 - 10:58 EDT

Investigating

We’re experiencing a potential ACH payment issue with collaborative AR and Payment Gateway. We'll provide an update as soon as more information becomes available.
Posted Apr 25, 2025 - 08:48 EDT
This incident affected: Payments (Versapay Payment Gateway (TPro4)) and Collaborative AR (formerly ARC) (Payment Services).