Collaborative AR - Multi-Invoice Payment Issues

Incident Report for Versapay

Resolved

The payments issue is resolved.

Users can now issue payments without issue.

We apologize for any inconvenience this has caused. If you have any questions, please contact support@versapay.com.
Posted Sep 08, 2025 - 18:02 EDT

Investigating

We’ve identified an issue affecting a few payment transactions that include multiple invoices where the order number is unusually long. To avoid this, the workaround is to pay the invoices individually. Our team is actively working on a fix to resolve this.
Posted Sep 08, 2025 - 16:50 EDT
This incident affected: Collaborative AR (formerly ARC) (Payment Services).